HTML笔记 ·

微信小程序支持npm包

在8月30号的时候,微信开发者工具进行了一次升级,在升级日志中我们看到微信小程序开始支持npm包管理了。但是小程序的基础版本库是从2.2.1版本开始支持,很遗憾的是在2.2.1以前的版本上则会报错。

和其他前端框架一样,首先得进行的是npm init,然后才是安装依赖包。在这里我们采用base64的一个包进行测试。

1.安装

个人比较倾向使用cnpm来进行安装,比较快,而且不用去修改npm的镜像位置

cnpm install --production -S js-base64

关于“--production”,在官方文档上有说明

此处并没有强制要求 node_modules 必须在小程序根目录下(即 project.config.js 中的 miniprogramRoot 字段),也可以存在于小程序根目录下的各个子目录中。但是不允许 node_modules 在小程序根目录外。请务必使用--production选项,可以减少安装一些业务无关的 npm 包,从而减少整个小程序包的大小。

2.在程序中引入

我们在首页的index中进行引入,

const Base64 = require('js-base64').Base64;

然后再onload函数中调用

onLoad: function () {
    console.log(Base64.encode("haha"));
    }

3.构建npm

点击开发者工具中的菜单栏:工具 --> 构建 npm
在工具栏最下方有一个选项就是构建npm,然后点击开发者工具右上角的详情,勾选上使用npm模块
微信小程序支持npm包
这里的勾选npm模块和小程序版本都要选择正确了,否则会提示:找不到模块如module "pages/npm/js-base64" is not defined

以上就是在小程序中使用npm的方法。

参与评论